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1 Introduction  

The DECT Handset Configurator is a tool for managing the configuration data of DECT handsets. The configuration data 
is stored on a memory card.  
 
Main features of the memory card interface  

 Edit contacts.  

 Modify phone settings.  

 Manage subscriptions.  
 

For details on the meaning and values of settings, refer to the document “Alcatel-Lucent 500 DECT Handset 
Localisation and notification handling - Configuration Guide », reference: 8AL90843USAA. 
 
Miscellaneous  

 Create subscription files for Easy Subscription.  

 Convert phonebook files or Central Directory database files to .CSV format. 

2 Requirements  

2.1 Supported DECT Handsets  

Only the 500 / 500EX DECT Handset is supported.  
Note: the configuration data of handsets may depend on the handset firmware version. Always make sure to use the 
latest version of the DECT Handset Configurator if you want to be able to manage the latest handset features.  
 
In the remaining of this document “500 DECT handset” apply both to generic 500 DECT handset and to 500EX DECT 
handset. 

2.2 Supported Memory Cards  

The DECT Handset Configurator only supports memory cards supplied with the 500 DECT handset.  
Catalog reference is 3BN67210AA - “500 DECT Handset memory card”. 
 
Other memory cards are not supported.  

2.3 Supported Card Readers  

The DECT Handset Configurator is developed for the ACR38T card reader from Advanced Card Systems 
(www.acs.com.hk). Local resellers of ACS products can be found on their web-site (e.g. www.cardomatic.biz).  

In France the ACR38T card reader can be purchased from Hitools Access (e.g. www.hitools-access.com) 
 
An alternative card reader is the Omnikey Cardman 6121 dongle. This reader can be purchased from local resellers 
(e.g. www.arp.com)  
 
Other card reader references are not supported. 

2.4 PC Requirements  

No special hardware requirements except an USB2.0 port for the card reader.  
The DECT Handset Configurator supports the following Windows versions:  
 

 XP Pro SP2, 32-bit version  

 XP Pro SP3, 32-bit version  

 Windows 7 Professional/ Enterprise/ Ultimate, 32-bit and 64-bit version  

 Windows 2003 Server SP2, 32-bit version  

 Windows 2003 Server R2 SP2, 32-bit version  

 Windows 2008 Server SP2, 32-bit and 64-bit version.  

 Windows 2008 Server R2, 32-bit and 64-bit version.  

 Windows .NET Framework version 4.0 must be installed. This is checked when installing the DECT Handset 
Configurator  

http://www.cardomatic.biz/
http://www.hitools-access.com/
http://www.arp.com/


DECT Handset Configurator 

 

 

 

8AL 90876 USAA ed01 4  

 

3 Installation  

3.1 Device Drivers  

Install the required device drivers for the used card reader before using the DECT Handset Configurator for the first 
time. Drivers are normally supplied by the device manufacturer.  

3.2 Tool Installation  

The DECT Handset Configurator is installed by running setup.exe. If not yet present the installer automatically installs 
.NET Framework 4.0 from the internet. If you have no network connection this component can be installed in advance. 
It can be found at www.microsoft.com/downloads (use search). 
 
 
 

4 Quick Memory Card Configuration  

To modify the data of a memory card perform the following steps: 

1. Remove the memory card from the handset.  

2. Place the memory card in the card reader and place the card reader in the PC's USB slot.  

3. Read the card data (Card->Read or press the Card Read icon on the toolbar).  

4. The handset menu tree is identical to the menu of the handset. By clicking the tree nodes the data is shown in 
the data panel and you can modify it as required. E.g. Menu->Settings-> General shows the general settings of 
the handset and you can e.g. modify the ring tones of the current profile.  

5. Instead of entering contacts manually you can also import them from a file (File->Import->Phone Book). The 
following files can be imported:  

 Central Directory database.  

 Comma Separated Values file.  

6. Write the modified data back to the memory card (Card->Write or press the Card Write icon).  

7. Remove the memory card from the reader and place it in the handset.  

8. The modified data can also be saved to a file (File->Save or File->Save as).  
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5 User interface 

5.1 Overview 

The picture below shows the main window of the DECT Handset Configurator. 

 

 Title bar. 
Shows operation mode and the current file.  

 Menu bar. 
Contains the menu items File, Card, Tools, and Help.  

 Tool bar. 
Contains a number of shortcuts to functions in the menu bar: 
File->New, Open and Save, Card->Read and Write. 
Some icons are only visible if the correct operation mode is selected.  

 Handset menu tree. 
Depending on the operation mode different menu tree's are displayed, resembling the menu of the managed 
handset. When an item is selected in the menu tree the related data is displayed in the data panel on the right 
side of main window.  

 Status bar. 
Shows the following information:  

o Program activity (idle, reading/writing card, sending)  

o A progress bar showing the progress when reading/writing or sending.  

o A phone number in case multiple send is busy.  
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5.2 File Menu  

The File Menu contains all file related functions of the DECT Handset Configurator.  
 

 

New  

Create a new file. All settings are set to default. All user data (e.g. phone 
book) is cleared.  

Open  

Open an existing file: .500.  

Save  

Save the current file. If no file was opened the user is prompted for a file 
name.  

Save As  

Save the current file with a different name.  
 

 

Import  

Import Phonebook  

Import phonebook data from a file. Supported file types: 

 Comma Separated Values (.csv).  

 Central Directory Database (.xls).  
Note: If the number of contacts of the handset is exceeded the imported list 
is truncated. 

Import Caller Filter  

Import a caller filter from a file. The supported file types are the same as 
for import phonebook. 

Import Subscription  

A single subscription can be imported from a Subscription File. The user is 
prompted for the following information: 

 Subscription File containing the subscription record to import.  

 Network number. Only a free entry can be selected. The handset can 
hold up to 4 subscriptions.  

 The network name to be related to the subscription.  

 The DNR (phone number) can be selected from a list.  

 

Export  

Export Phone Book  

The current phone book is exported to a .CSV file (Comma Separated Values) 

Export Caller Filter  

The current caller filter is exported to a .CSV file.( Comma Separated 
Values) 

Exit  

Close the DECT Handset Configurator. 

 

image%20file.htm
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5.3 Card Menu  

The Card Menu contains all memory card related functions of the DECT Handset Configurator. 

 

Read  

Read the contents of a memory card to the PC memory. The memory card 
data can now be modified.  

Write  

Write the current data to a memory card.  
Important notes: 

1. All user data and phone settings on the memory card are 
overwritten. If this is not what you want first read the memory card, 
make the required modifications and then write the data back to the 
memory card.  

2. Subscription data on the memory card is normally not affected when 
writing the memory card, but there is one exception: after importing 
a subscription (File->Import Subscription) and writing the memory 
card the old subscriptions on the card will be gone. To prevent this 
first read the memory card before importing subscriptions. The new 
subscriptions will then be added to the old ones. 

Write Batch  

This function is part of the Easy Subscription feature. Using a Subscription 
File a batch of memory cards can be programmed. The user is prompted for 
the following information: 

 Subscription File containing the subscription records (1 for each 
memory card).  

 The network name related to the subscriptions.  
Next the user is prompted to enter a memory card into the card reader for 
each of the subscription records in the Subscription File 

Important note: all existing subscriptions on the memory cards are 
deleted! 

Clear  

Returns a memory card to the empty, unformatted state. 
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5.4 Tools Menu  

 

Create Subscription File  

This function is part of the Easy Subscription feature. It generates a 
Subscription File that can imported into a DECT system. 
The user is prompted to enter the following information: 

 An input file containing the name and number of each subscription. 
Supported file types:  

o Comma Separated Values (.csv).  
o Central Directory Database (.xls).  

 The PARI of the DECT system.   

 When multi-site subscriptions are created the SARI must also be 
entered.  

Convert Phonebook  

Converts any of the following files to : 

 Comma Separated Values file (.csv).  

 Central Directory Database (.xls).  
 

5.5 Help Menu  

 

Contents  

Enters this help facility. 

About  

Displays copyright and version information. 

 

6 Handset menu tree 

6.1 Messaging  

The "Messaging" Menu Tree Item contains the following items: 

 New and Draft  

 Inbox  

 Sent Messages  

 Settings  
Currently only the "Settings" menu item is implemented. 

6.2 Contacts  

The contacts list contains up to 200 entries. Each entry contains the following info: 

 Name (maximum 24 characters).  

 Up to 4 phone numbers (maximum 32 digits). For each phone number a number type (Business, Mobile, Home 
or Other) can be selected.  

 An optional speed dial number (9 speed dials in total for the entire list).  
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By clicking on the list the following context menu is activated: 
 

 
 

Other ways to add contacts to the list are: 

 Read from a memory card (Card->Read).  

 Import from a file (File->Import->Phone Book).  

 Open an Image File containing the broadcast groups (File->Open)  
Note: the contacts list is located in your PC's memory. Saving the list to a memory card is done with Card->Write.  

6.3 Settings  

Identical to the "Settings" menu item of the 500 DECT handset. It contains the following items: 

 General  

 Sounds & Alerts  

 Display  

 Calls  

 Connectivity  

 Security - Alarm settings: contains the Alarm settings and Alarm ack settings entries in the General tab, 
Security entry. 
For more details regarding the parameters meaning and values, please refer to the 500 DECT configuration 
guide for Location and Notification handling 8AL90843xxAA.  

By pressing a sub-menu item the related settings are shown and can be modified. 
 
Note: the modified settings are located in your PC's memory. You can make the changes permanent by saving them to 
a memory card with Card->Write. 
 

6.4 Calls  

In a 500 DECT handset the following call logs can be displayed: 

 All.  

 Answered.  

 Dialled.  

 Missed.  
By clicking on the list a context menu is activated. Only deleting one or more call log entries is supported. 
 

6.5 Calendar 

Not implemented. 
 

6.6 Accessories 

Not implemented. 

6.7 Environment Muting  

Set the environment muting settings of the 500 handset.  

image%20file.htm
mk:@MSITStore:Z:\infra_alize\doc-divers\IPDect\Dect%20Handset%20Configurator\help.chm::/card%20menu.htm
mk:@MSITStore:Z:\infra_alize\doc-divers\IPDect\Dect%20Handset%20Configurator\help.chm::/card%20menu.htm
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6.8 Central Directory  

Set the central directory settings of the 500 handset.  

 

7 File type 

7.1 Image File  

The image file (type .500) contains all data located on a 500 DECT handset memory card. After an Image File is opened 
(File->Open) the data can be modified with the tool and saved back to a file (File->Save). The data can also be written 
to a memory card (Card->Write). 
 
NOTE: 
The subscription data is NOT stored in the Image File. Subscriptions are only visible after an import action  
(File->Import, Subscription) or after reading a memory card (Card->Read). 

7.2 Subscription File  

The subscription file (type .XML) contains one subscription record for each handset. This file is used to import 
subscriptions into a DECT system using the DAP Manager. The same file is used by the DECT Handset Configurator to 
generate subscription data for the memory cards. 
 
Subscription files can be created with the DECT Handset Configurator (Tools->Create Subscription File). Input for this is 
a Comma Separated Values file containing name-number combinations or a Central Directory Database. 

7.3 Comma Separated Values  

The Comma Separated Value file format (type .CSV) is often used to exchange data between applications. The file 
format, as it is used in Microsoft Excel, has become a pseudo standard for this purpose. The DECT Handset Configurator 
uses CSV files for storing phone books. Each entry in the CSV file contains a name and 1 to 4 phone numbers. The 
format of the CSV file entries is as follows: 
 
<name>,<number1>[,number2][,number3][,number4] 
 
Note 1: When a name contains a comma the entire name must be enclosed by double quotes. Example: "Smit, John", 
12345. 
 
Note 2: CSV files can be created using Excel. However depending on regional settings Excel uses a semicolon as a 
separator in stead of a comma. This format is also supported by the DECT Handset Configurator. 
 

7.4 Central Directory Database  

A Central Directory Database can be stored in a Microsoft Excel Sheet (type .XLS), see the example below. The file 
consists of a single sheet called "directory". This name is mandatory. Also the column headers shown in the example 
are mandatory. More info about this subject can be found in the DECT CE Manual. 
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8 How to … 

8.1 Prepare a New Memory Card  

Card Preparation Using a Handset  

The supplied memory cards are empty and unformatted. When an empty memory card is placed in a handset and the 
handset is switched on it performs the following initialisation procedure:  

 Format the memory card.  

 Copy all data from internal handset memory to the memory card.  

 Remove the subscription data from the internal handset memory.  
The handset will now use the data from the memory card. The data on the memory card can be managed with the 
DECT Handset Configurator as described in Quick Start Memory Card Configuration.  

Card Preparation Using DECT Handset Configurator  

If no phone data must be copied to the new memory card the card can be prepared using the DECT Handset 
Configurator. Just enter the memory card in the reader and open a new file (File->New). Modify all data as required 
and write it to the card (Card->Write). The card can now be placed in the handset.  

Clear Memory Card  

It is possible to clear a memory card so it returns to the empty, unformatted state with Card->Clear. 
 

8.2 Make Easy Subscriptions  

Introduction 

Subscribing DECT handsets in the traditional way is a time consuming activity, especially for large installations. This 
includes entering the subscription menu on the handset, entering the PARK code, the PIN code, the system name and 
the phone number. Also the user name can be entered on the handset. When the subscription is successful the handset 
is ready for use. It may also be required to modify some of the default phone settings (e.g. the emergency number and 
text, pre-defined phone numbers, etc.). When the subscriptions are prepared at the suppliers site the handsets must 
be repackaged for shipment to the customer. 
With the iSMobile Easy Subscription facility the total handling time for handset subscription is reduced dramatically.  
 
Note: currently the Easy Subscription feature is only available for OmniPCX Enterprise solutions. 

What do you need?  

1. 500 DECT handsets.  
2. A memory card for each handset.  
3. An ACR38 card reader.  
4. The DECT Handset Configurator.  
5. A file (.CSV) containing the user names and related phone numbers. 

A Central Directory Database (file type.XLS) can also be used.  
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How does it work?  

 

1. Using the DECT Handset Configurator a Subscription File (.XML) is created (Tools->Create Subscription File). 
Input is a CSV File containing the names and numbers of all handset users. Alternatively a Central Directory 
Database (file type .XLS) may be used. The user also enters the PARI of the DECT system and selects the 
directory where the output XML Subscription File will be stored. 

2. When default phone settings (including contacts) must be modified for all users this is done now. The phone 
settings can also be loaded from a template stored in an image file (.500).  
 
With the DHC tool open the "create subscription file", select the PARI of the PABX , input .csv or .xls file and 
give the directory of the XML file which is created by the DHC tool. 

3. Start a batch write (Card->Write Batch). The tool reads the Subscription File that was generated in step 1 and 
prompts to enter a memory card for each subscription in the batch. The cards are loaded with the subscription 
data, system name, user name and all phone settings prepared in step 2.  

4. The handsets, memory cards and Subscription File are shipped to the customer.  

5. At the customers site the Subscription File is imported into the system with the DAP manager. All subscriptions 
get the status subscribed.  

6. The handsets are distributed. After placing the memory cards and the batteries the handsets are operational.  

 

Importing subscriptions at the customer site 

Start the IPDECT configurator, Click box "Modify System, select the valid system, click "Active/deactive/System 
status", press "Start", the DAP manager starts. 
Select Main, click “PackUp & Go” , Import, select the .xml file created by the DHC tool and click OK. 
New subscriber entries are imported in the subscriber list. 

Multi-site subscriptions  

When a Subscription File  is created you are prompted to enter the systems PARI. For multi-site subscriptions also the 
SARI must be entered. So for multi-site handsets a separate Subscription File must be generated which is also imported 
into the DECT system.  
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